Storage Device Control Policy Failing on Scanned devices

  • 7021198
  • 11-Aug-2017
  • 01-Sep-2017

Environment

ZENworks Configuration Management 11.4.2 Policies

Situation

Storage Device Control Policy Failing on Scanned devices
The USB devices that were previously restricted in the policy, are now an Allowed device in the policy, but the devices are not being detected.

After upgrading from v11.4.1 > v11.4.2 the Storage Device Control Policy running in ZENworks v11.4.2 is failing.
Then upgraded to v11.4.3 (or higher), Storage Device Control Policy is still failing.




Resolution

Recreate Storage Device Control Policy.

Workaround #1: Use a USB Connectivity Policy instead of the Storage Device Control Policy.

Workaround #2: Edit the Devices in the Preferred Device list and remove Manufacturer, Product, VendorID and ProductID from all devices.
This allowed the existing policy to work correctly still blocking other USB devices not on the list.


Cause

The Storage Device Control Policy UI in ZCC is storing the VendorID and ProductID in the "Preferred Devices" list in the database as hexadecimal instead of plain decimal. 

Since the code in ZESM Agent that is used to interpret these values is the same code that is used to interpret the values from the "USB Device Access Settings"  list of the USB Connectivity Policy, the comparison of the device's VendorID and ProductID with that of the filter will fail in the case of a Storage Device Control Policy.


Additional Information

Defect 995780
Fixed in v11.4.3
If using v11.4.1 and upgraded to v11.4.2 and then upgraded to v11.4.3 or v2017 this Policy may still fail.
Use workarounds.