External User is unable to login after creating an account in Filr

  • 7021108
  • 18-Jul-2017
  • 18-Jul-2017

Environment

Novell Filr

Situation

External users unable to log into Filr after creating an account and clicking the confirmation email
/var/opt/novell/tomcat-filr/logs/appserver.log reports:
2017-07-14 14:42:05,051 WARN  [http-apr-8443-exec-75] [com.novell.teaming.module.authentication.impl.PlusAuthenticationProviderModule] - [client 151.155.212.50] user testuser: authentication failure: org.springframework.security.core.userdetails.UsernameNotFoundException: User testuser not found in directory.

Resolution

There could be a few reasons why external users aren't able to log into Filr after creating an account. Follow these steps to see if they help resolve the issue:

  1. Login to the Filr Administration Console and navigate to LDAP Configuration:
    • Log into Filr 8443 port as admin
    • Navigate to the admin console by clicking the user name in the top right had corner and clicking Administration Console
    • On the left hand side, under System, click LDAP

  2. Configure access for local user accounts:
    • Click the far right tab labeled Local User Accounts
    • Check the box next to Allow log in for local user accounts (i.e user accounts not in LDAP)
    • Click OK to save the changes

  3. Test to see if external users can log in

Cause

Local user accounts are any accounts that are not in LDAP. In this instance, Filr considers External Users as a local user account and this setting needs to be enabled.