Environment
Novell GroupWise
Windows Server 2012
Windows Server 2012
Situation
When loading WebAccess, it times out and states "Service Not Available"
The WebAccess log at C:\Novell\Groupwise\WebAccess\logs only showed "[EA06] Invalid Session String"
The Tomcat log at C:\Novell\tomcat8\logs\catalina.(date) stated the real reason of the tomcat crash.
Java.lang.OutOfMemoryError: Java Heap space
The WebAccess log at C:\Novell\Groupwise\WebAccess\logs only showed "[EA06] Invalid Session String"
The Tomcat log at C:\Novell\tomcat8\logs\catalina.(date) stated the real reason of the tomcat crash.
Java.lang.OutOfMemoryError: Java Heap space
Resolution
- Change the Java Heap memory size
- Browse to C:\Novell\tomcat8\bin and execute the application tomcat8w.exe
- Select the Java tab, then set Initial memory pool: and Maximum memory pool: to something higher
Note: default minimum is 128 MB, maximum 256 MB
- Restart Apache Tomcat
- Open Component Services - Server Manager > Tools > Component Services
- Select Services (Local)
- Select Apache Tomcat > click the Restart link
Cause
Java heap size should be bigger depending on the number of users using WebAccess.