sudo-1.8.10p3-10.10.2 - sorry, you must have a tty to run sudo.

  • 7021027
  • 27-Jun-2017
  • 30-Jun-2017

Environment

SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Server 12

Situation

Following the installation of sudo-1.8.10p3-10.10.2, the "sudo -l" commands returns the following:

     sudo: sorry, you must have a tty to run sudo

Resolution

There are two workarounds available :

Option 1 : Remove the "Defaults requiretty" line from the sudoers file .
Option 2 : Revert to sudo-1.8.10p3-10.5.1

Cause

The root cause for this is due to a bug in the fix for CVE-2017-1000368.

Additional Information

This has been reported to engineering.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.