SSL configuration fails Test or Save in LDAP / Active Directory Setup

  • 7021015
  • 23-Jun-2017
  • 23-Jun-2017

Environment

Micro Focus Service Desk 7.3 LDAP
Micro Focus Service Desk 7.4 LDAP
Micro Focus eDirectory
Microsoft Active Directory
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)

Situation

  • Service Desk installed on SLES 12 SP1
  • IBM Java is installed on the Service Desk server
  • Configuring LDAP / Active Directory in Service Desk
  • Using SSL - Anonymous or SSL - Username + Password Security setting
  • Clicking Test or Save after entering the details

The following error is seen in the web console:

ERROR:
Connection Test: Failed
"Unable to connect to the server: Protocol communication error.


The following error is seen in LiveTime.log:

ERROR:
(SecureSocketFactory.java:116) - An unknown error occurred
java.security.NoSuchAlgorithmException: SSLv3 SSLContext not available
    at sun.security.jca.GetInstance.getInstance(GetInstance.java:171)

Resolution

  1. Uninstall IBM Java from the Service Desk server
    Example command:
    zypper rm java-1_8_0-ibm
  2. Reboot the Service Desk server
  3. Reconfigure LDAP / Active Directory Setup

Cause

$JRE_HOME environment variable is pointing to a non-supported Java version.

Additional Information

Only the Oracle Java Development Kit (JDK) is supported for use with Service Desk.

Do the following to verify which Java Runtime Environment (JRE) is being used:
  1. Run the following command:
    echo $JRE_HOME
    Example output:
    /usr/java/latest/jre
  2. Run the following command (Change the beginning according to above echo command output):
    /usr/java/latest/jre/bin/java -version
  3. Verify that the version listed is pointing to the JRE installed with the Oracle JDK