OES 2015 iPrint ipcon page can't find the Print Manager

  • 7020157
  • 02-Jun-2017
  • 29-Nov-2017

Environment

Micro Focus Open Enterprise Server 2015 SP1

Situation

After authenticating to the ipcon tool (https://<iPrintServerAddress>/ipcon), the page loads, but the Print Manager is not found and printer agents are not listed. 

To understand what is meant by "not found", look at the top blue banner within the page. Notice the "Connect to:" field. When this problem exists, that field will be blank.  Clicking the drop down list may find the print manager name, but selecting it will not change the symptom.

Resolution

There are options to getting past this problem:
  1. Log in with fully qualified admin name
    • syntax:
      • cn=admin,o=<organization name>
    • example:
      • cn=admin,o=mycompany
  2. Log in with case correct admin
    • Using iManager, find the admin user object.  Take note of the case.
      • For example, admin vs Admin
    • Log into the /ipcon tool with the admin user using the correct case.

If the problem continues, follow these steps:

  • Open the /etc/opt/novell/iprint/httpd/conf/iprint_ssl.conf file.
  • Find the AuthLDAPDNURL "ldaps://<server IP or DNS>:636/o=<Organization>???(objectClass=user)" line.
    • The <server IP or DNS> will show the actual server's IP address or DNS name
    • The <Organization> will show one of the tree's actual eDir Organization names.
  • Remove the o=<Organization> text.  The line will look something like this:
    • AuthLDAPDNURL "ldaps://<server IP or DNS>:636/???(objectClass=user)"
  • Save the change.
  • Restart Apache
    • rcapache2 restart



Cause

There is a bug where the authentication to the ipcon tool is case sensitive when logging in with the just the CN (Common Name).  Note: the Common Name is the user without the context.  Micro Focus is looking into this problem.