Apache 2.4 not detected when installing Retain on SLES 12

  • 7019098
  • 02-Feb-2016
  • 07-Aug-2017

Environment


Retain 4.0 on SLES 12
Note: Retain 3 is NOT supported on SLES 12

Situation


Apache not detected when installing Retain on SLES 12

Resolution

Some installations of Apache 2.4 on SLES 12 do not put a file (find_mpm) needed by Retain to use the Web Server.

To resolve this:

  1. Copy the find_mpm file from depricated-scripts to the apache2 directory
    Example: cp /usr/share/apache2/depricated-scripts/find_mpm /usr/share/apache2/
     
  2. Make sure the find_mpm is executable.
    Example: chmod +x /usr/share/apache2/find_mpm

You should now be able to run the Retain installer as normal.

Note: This is a bug in the Retain installer and is resolved in 4.0.1.  Bug number RET-5289.

Additional Information

This article was originally published in the GWAVA knowledgebase as article ID 2718.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.