Receiving a Warning that Your Internet Browser is not supported/compatible when on a supported version of Internet Explorer

  • 7018901
  • 10-May-2017
  • 10-May-2017

Environment

Novell ZENworks Configuration Management 11.4

Situation

You receive "Your internet browser is not supported by this version of ZENworks Control Center. While many functions will work, this browser version has not been fully tested...." on ZCC Login while being on a supported browser and version.

When you attempt to use/install a plugin, you receive the message: "Novell ZENworks XXXXX is currrently not compatible with this browser. For a list of supported browsers, see the Adminsitrator Browser Requirements section under ZENworks Configuration Management Instllation Guide..."
while being a supported browser and version.

Resolution

1. Ensure Compatibility View is disabled in IE (Tools->Options->Compatiblity View Settings).

2. If only one instance of iexplore.exe (and not iexplore.exe *32) is appearing in task manager->processes:

Disable "Enable Enhanced Protected Mode*" by unchecking in Internet Explorer->Tools->Internet Options->Advanced tab, 
then click Apply and OK and restart system.


Also Check the registry in the following locations:

HKCU\Software\Microsoft\Internet Explorer\Main\Isolation="PMEM", edit to "PMIL" and restart system.

HKLM\Software\Microsoft\Internet Explorer\Main\Isolation="PMEM", edit to "PMIL" and restart system.

HKCU\Software\Policies\Microsoft\Internet Explorer\Main\Isolation="PMEM", edit to "PMIL" and restart system.

HKLM\Software\Policies\Microsoft\Internet Explorer\Main\Isolation="PMEM", edit to "PMIL" and restart system.


HKCU\Software\Microsoft\Internet Explorer\Main\TabProcGrowth=0, edit to 1 or another value and restart IE.

HKLM\Software\Microsoft\Internet Explorer\Main\TabProcGrowth=0, edit to 1 or another value and restart IE.

HKCU\Software\Policies\Microsoft\Internet Explorer\Main\TabProcGrowth=0, edit to 1 or another value and restart IE.

HKLM\Software\Policies\Microsoft\Internet Explorer\Main\TabProcGrowth=0, edit to 1 or another value and restart IE.


3. You may also try to "Reset Internet Explorer settings to their default condition" and "Restore Advanced settings" and 
uninstalling/reinstalling Internet Explorer. Also check relevant/related GPO settings as well.

Cause

IE is mis-configured