Printer Driver Profile data missing after May 2017 update

  • 7018880
  • 05-May-2017
  • 08-May-2017

Environment

Micro Focus Open Enterprise Server Support Pack 1 with iPrint installed.

Situation

After applying the "iPrint for OES - Enabler Patch 11109", some printer driver profiles no longer exist within the Print Manager database.  The printer driver profile association is still present, but the data is not. 

For example, go to iManager -> iPrint -> Manager iPrint Printer -> Select the printer -> Drivers.  Look at the "Profile:" attribute.  The profile name will be present.  However, look at the "Available driver profiles for selected driver".  The list will show [None]. 

Also, when attempting to install that printer, an error message will be shown informing the end user that the profile does not exist. 

Resolution

  1. Copy XML file to /tmp directory
    • The Print Manager creates and maintains back up copies of the database.  Review the XML files within the /var/opt/novell/iprint/<print manager name.ou.o>.psm/ directory.  Determine the most recent XML file which has all the printer profile data. Note, profile data is at the end of the XML file.
      • padbtxt.xml - Most recent XML, likely does not have all the profile data.
      • padbtxt1.xml - 2nd most recent XML, might have all the profile data.
      • padbtxt2.xml - 3rd most recent XML, likely has all the profile data.
    • Syntax:
      • cp /var/opt/novell/iprint/<print manager name.ou.o>.psm/<AppropriateXMLFile> /tmp/padbtxt-import.xml
    • Example:
      • cp /var/opt/novell/iprint/prntmgr.sales.chicago.abc.psm/padbtxt1.xml /tmp/padbtxt-import.xml
  2. Import the XML
    • Copy/paste the following string of commands into a terminal session:
      • sed -i 's/driverupdateenabled>1/driverupdateenabled>0/' /tmp/padbtxt-import.xml;rcnovell-ipsmd stop;/opt/novell/iprint/bin/ipsmd -b
    • Modify the following string of commands to be appropriate for your environment:
      • Syntax:
        • rcnovell-ipsmd stop;/opt/novell/iprint/bin/ipsmd -x /tmp/padbtxt-import.xml -u cn=admin,o=<OrganizationName>;rcnovell-ipsmd start
      • Example:
        • rcnovell-ipsmd stop;/opt/novell/iprint/bin/ipsmd -x /tmp/padbtxt-import.xml -u cn=admin,o=abc;rcnovell-ipsmd start
          • Provide the admin password when prompted and hit ENTER.
Note:  Do not restart the Print Manager after taking this step or the problem will return.  If the problem returns, follow these steps:
  • rcnovell-ipsmd stop;/opt/novell/iprint/bin/ipsmd -b
  • Modify the following string of commands and execute it:
  • rcnovell-ipsmd stop;/opt/novell/iprint/bin/ipsmd -x /tmp/padbtxt-import.xml -u cn=admin,o=abc;rcnovell-ipsmd start
To prevent this problem from happening after a restart of the ipsmd process (Print Manager service), apply the follow-up May 2017 OES 2015 SP1 Hot Patch for iPrint 11145.

Cause

There is a bug in the "iPrint for OES - Enabler Patch 11109" update which deletes profiles in some cases with some characters being present in the driver name.  The problem is intermittent.

Additional Information

This issue is caused by an iPrint update to OES which was released 03MAY2017.  A Hot Patch was released 08MAY2017 in response to the 03MAY2017 introduced problem.  Therefore, iPrint servers which got updated between 03MAY2017 and 08MAY2017 will see this problem.  Servers updated after 08MAY2017 will not see the problem.  For those servers updated during the problem time window (03MAY2017 to 08MAY2017) the steps above will need to be taken to recover the missing profiles and the 08MAY2017 update will need to be applied to prevent the problem from re-occurring after a Print Manager restart.