Failed Authentication installing SSL printers and blank Directory Servers page in the MC

  • 7018829
  • 25-Apr-2017
  • 25-Apr-2017

Environment

Micro Focus iPrint Appliance 3.0

Situation

This problem expresses itself with the following two symptoms:
  • "Failed authentication" message when trying to install a secure printer.
  • Accessing the Directory Servers page within the iPrint Appliance Management Console (https://<address>:9443) returns a blank page.  The configured server data is no longer available.

If PaperCut is installed (a third party printing accounting software), it does not work.

Resolution

  1. Edit the /opt/novell/filr/apache-tomcat/conf/server.xml and remove duplicate entries of portHeader="x-forwarded-port". Below is a correct example of this:
    • <Valve className="org.apache.catalina.valves.RemoteIpValve" internalProxies=".*" protocolHeader="x-forwarded-proto" portHeader="x-forwarded-port" proxiesHeader="x-forwarded-by" remoteIpHeader="x-forwarded-for"/>
  2. Restart the Filr process:
    • rcfilr start
See the Additional Information section of this document for a problematic example.

Cause

The /opt/novell/filr/apache-tomcat/conf/server.xml had duplicate entries which caused the Filr process to crash upon loading.  Specifically, portHeader="x-forwarded-port" had been duplicated several times.  The issue is being investigated by engineering.

Additional Information

A sample of a problematic entry:

<Valve className="org.apache.catalina.valves.RemoteIpValve" internalProxies=".*" portHeader="x-forwarded-port" protocolHeader="x-forwarded-proto" portHeader="x-forwarded-port" portHeader="x-forwarded-port" portHeader="x-forwarded-port" portHeader="x-forwarded-port" portHeader="x-forwarded-port" proxiesHeader="x-forwarded-by" remoteIpHeader="x-forwarded-for"/>

To check whether or not Filr is running:
rcfilr status