Environment
Micro Focus Open Enterprise Server 2015 (OES 2015) Linux Support Pack 1
Micro Focus iPrint Appliance 2.x
Micro Focus iPrint Appliance 3.x
Micro Focus iPrint Mac client 6.0x
Micro Focus iPrint Appliance 2.x
Micro Focus iPrint Appliance 3.x
Micro Focus iPrint Mac client 6.0x
Situation
Trying to install an iPrint printer to a Mac computer thru the browser with the proxy configuration set results in the following error:
IPPTrace shows:
Trace Info: /Users/doe/workspace/iprint-mac-client-trunk/iprintmacclient/iprint-library/Sources/mydoreq.c, line 939
Group Info: CUPS-IPP
Error Code: 1024 (0x400)
User ID: 501
Error Msg: iPrint Client - The request contained bad syntax.
Debug Msg: MyCupsDoFileRequest - IPP BAD REQUEST
IPPTrace shows:
Trace Info: /Users/doe/workspace/iprint-mac-client-trunk/iprintmacclient/iprint-library/Sources/mydoreq.c, line 939
Group Info: CUPS-IPP
Error Code: 1024 (0x400)
User ID: 501
Error Msg: iPrint Client - The request contained bad syntax.
Debug Msg: MyCupsDoFileRequest - IPP BAD REQUEST
Resolution
Contact Micro Focus Technical Services to obtain a new iPrint Client for Mac with the fix.
The updated iPrint Client for Mac will work thru proxy only for non-secure iPrint printers. The Micro Focus iPrint engineering team is continuing work to resolve this problem for secure (SSL) iPrint printers. This TID will be updated when the SSL fix is also available.
The updated iPrint Client for Mac will work thru proxy only for non-secure iPrint printers. The Micro Focus iPrint engineering team is continuing work to resolve this problem for secure (SSL) iPrint printers. This TID will be updated when the SSL fix is also available.
Cause
The iPrint Client for Mac sends an incorrect URL when configured to go through a proxy server.