Environment
NetIQ Sentinel Unix agent 7.4
Situation
Sentinel Unix Agent 7.4 is not forwarding the Real username field to Sentinel for BSM events. Thus when the person switches to couple of users, the operations are still being shown as done by the logged in or effective user.
Resolution
To resolve this issue on Sentinel install hotfix 7.4 HF15 from https://dl.netiq.com/patch/finder/ location
Cause
Real username of subject token is not being forwarded to sentinel server. Therefore sentinel is unable to populate the real username information.