Environment
NetIQ Privileged Account Manager
Situation
Adding an Oracle Database Account Domain in the Enterprise Credential Vault, selecting Test Connection reports the following error status:
ORA-12154: TNS:could not resolve the connect identifier specified
ORA-12154: TNS:could not resolve the connect identifier specified
Resolution
The provided Connect String in the Account Domain may have a syntax error(s). Please look for unmatched parentheses or stray characters.
Cause
Syntax error in the Connect String.
Additional Information
For example, the following Connect String may cause this error because it has an extra, unmatched parentheses:
(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(Host=<IP address of the database that you have configured>)(Port=<configured port number>))(CONNECT_DATA=(SID=orcl))))
The above should be corrected with the extra unmatched parentheses stripped:
(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(Host=<IP address of the database that you have configured>)(Port=<configured port number>))(CONNECT_DATA=(SID=orcl)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(Host=<IP address of the database that you have configured>)(Port=<configured port number>))(CONNECT_DATA=(SID=orcl))))
The above should be corrected with the extra unmatched parentheses stripped:
(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(Host=<IP address of the database that you have configured>)(Port=<configured port number>))(CONNECT_DATA=(SID=orcl)))