PBA Authentication goes into boot loop on HP 600

  • 7018444
  • 04-Jan-2017
  • 04-Jan-2017

Environment

Novell ZENworks Full Disk Encryption 11.4

Situation

Installing the agent with ZESM Agent and enabling encryption with PBA login.
After logging into PBA, the device goes into a reboot loop.

Resolution

Work around:
Apply to v11.4.x FDE Policy DMI.INI configuration change in the policy to get the machine to boot. 
This seems to take ~120 seconds to complete. 
This only occurs on startup/boot.

Adding the following lines to the last part of the FDE policy (dmi,ini. config settings) will get the HP 600 to boot, it just takes 2 minutes at the "loading GRUB" prompt:

[HP,HP ProDesk 600 G2 SFF]
DMI_SYS_VENDOR=HP
DMI_PRODUCT_NAME=HP ProDesk 600 G2 SFF
KICKSTART=KEXEC
KERNEL_PARAM=pci=snb-enable-ahci-to-legacy

Cause

ZCM v11.4.x Linux kernel doesn't support this behavior natively.

Reported to Engineering -
Requires a new Linux kernel coming in a future update to ZENworks 2017 to fix this behavior in the newest HP 600 G2 model experiencing this behavior.
The long term switch to the new Linux kernel will not require any additional changes and will not have any boot delay.

Status

Reported to Engineering

Additional Information

Failing case occurs:
ZCM v11.4.2 & ZCM v11.4.3
On Hardware device:
OS Microsoft Windows 7 Professional Version 6.1.7601 Service Pack 1 Build 7601 System Manufacturer HP System Model HP ProDesk 600 G2 SFF System Type x64-based PC Processor Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz, 3201 Mhz, 4 Core(s), 4 Logical Processor(s) BIOS Version/Date: HP N02 Ver. 02.10, 4/7/2016 SMBIOS Version 2.7