Not able to establish the connection using SDK

  • 7018370
  • 07-Dec-2016
  • 13-Dec-2016

Environment

NetIQ Sentinel 7.4.4 Sentinel SDK

Situation

A connection cannot be made to Sentinel from the SDK.

Resolution

The workaround to make a connection to Sentinel from SDK, is to use the new password of the keystore(s) and replace the hard-coded password in the SDK's configuration.xml file with it. 

Two approaches to replacing the password in the xml file -  

1) Say on the Sentinel box, you change the keystore password to "novell". You can replace "password" with "novell" in the in the directory current/sdk/build/lib/connections/sentinel/config/configuration.xml or

2) The keystore passwords on the Sentinel box are stored in configuration.properties file in /etc/opt/novell/config/ in encrypted form. That encrypted password can be copied and used to replace the password in the configuration.xml file in SDK.

Cause

When the keystore passwords are changed in Sentinel using the chg_keystore_pass.sh script, it affects the SDK. A connection cannot be made to Sentinel from the SDK.   The reason being that the password is hard-coded in SDK. The hard-coded password in SDK is "password" as it was the password for the Sentinel keystores earlier.  The path to the configuration file in SDK is "current/sdk/build/lib/connections/sentinel/config/configuration.xml".