iCM settings not being apply to users thru windows 2012 R2 server

  • 7018347
  • 02-Dec-2016
  • 07-Dec-2016

Environment

Micro Focus iPrint Appliance 2.1 Patch 1
iCM enable on user object on the Appliance

Situation

When users log onto windows 2008 R2 server via Citrix session or RDP, first user got the iCM settings applied but the  second one not. There is no iCM activity

Resolution

Contact with Micro Focus support to get a FTF iprint client with the fix for this issue

Cause

When user logs thru windows server, iprint client downloads the iprint.ini file from the appliance, reads to apply the settings and deletes it from the local drive (c:\ndps\ACU). Under some circumstances, iprint.ini is not deleted so when next user logs in and try to download the iprint.ini file, it fails as the iprint.ini file is already present and owned by the first user.

Additional Information

An IPP Trace shows the error when trying to override the iprint.ini file:

[0000051C :    4130359ms][NIPPLIB] - IppGetFile - failed to CreateFile (5)
[NIPPLIB] - Access Denied 

[user name][thrd=0000051C][   4130375ms][NIPPLIB] - TCPDisconnect socket=488

[user name][thrd=0000051C][   4130375ms][NIPPLIB] - IppDestroyServerRef(E50DAED0)

[user name][thrd=0000051C][   4130375ms][NIPPLIB] - GetiPrintINIFromServer - IppGetFile(http://applaince name/ippdocs/iprint.ini) failed

[user name[thrd=0000051C][   4130375ms][NIPPLIB] - iCMSettings: Enabled: 0, Scope: , DirSrvr: