Environment
Self Service Password Reset 4.x
Internet Explorer 11
Situation
After upgrading/installing Self Service Password Reset 4.x, login to the SSPR Portal is successful, but attempting to access Configuration Manager or Configuration Editor throws the following error:
SSPR 5027 You do not have permission to perform the requested action.
Resolution
Disable Compatibility View in Internet Explorer for the domain that hosts your SSPR webapp.
Alternatively - Use Mozilla Firefox or Google Chrome instead.
Cause
This error only occurs in Internet Explorer. It also happens on version 11, despite the incompatible version error.
This issue occurs if the Internet Explorer settings are set to Compatibility View. To provide a full example of the scenario, consider the following:
In an example domain of testdomain.com: There is one webapp that is http://webapp.testdomain.com which requires compatibility view turned on in Internet Explorer to function correctly. There is also another webapp http://sspr.testdomain.com under the same domain. Internet Explorer only enables it for the domain, and ignores subdomains. So the setting in Internet Explorer would see testdomain.com only, and those Compatibility Settings would apply to both webapp.testdomain.com and sspr.testdomain.com.
SSPR 4 requires IE 11, and enabling Compatibility View essentially makes the website use antiquated IE 8 (or older) settings. Because of this, SSPR cannot properly function.