iPrint Appliance 2.1 email notification not sent

  • 7018111
  • 28-Sep-2016
  • 04-Oct-2016

Environment

iPrint Appliance 2.1
Microsoft Exchange server 2010 sp3

Situation

When submitting an email to be processed by an iPrint printer within the Appliance 2.1, the expectation is that an email notification is returned to the sender letting them know the status of the print job.  That notification is not being sent to the sender.

Resolution

On the Exchange server, go to the properties of the user defined in the Appliance's Global Email Settings.  Change the "send as" permission for the user.

https://technet.microsoft.com/en-us/library/bb676368(v=exchg.141).aspx


Cause

The user account configured to authenticate to the Email Exchange server did not have rights to send as another account.  This resulted in the SMTP server rejecting the email from the Appliance. 

Additional Information

A LAN trace shows the Appliance communicating with the SMTP server.  After TLS negotiation, the connection is dropped.
SMTP (Exchange) server log files show the failure:

EHLO smtp server,
250-smtp server Hello [1xx.xx.xx.xx],
250-SIZE,
250-PIPELINING,
250-DSN,
250-ENHANCEDSTATUSCODES,
250-AUTH NTLM LOGIN,
250-X-EXPS GSSAPI NTLM,
250-8BITMIME,
250-BINARYMIME,
250-CHUNKING,
250-XEXCH50,
250 XRDST,
AUTH LOGIN,
334 <authentication response>,
334 <authentication response>,
SMTPSubmit SMTPAcceptAnyRecipient BypassAntiSpam AcceptRoutingHeaders,Set Session Permissions
appliance user,authenticated
235 2.7.0 Authentication successful,
NOOP,
250 2.0.0 OK,
MAIL FROM:<appliance email address>,
receiving message
550 5.7.1 Client does not have permissions to send as this sender,
RSET,
50 2.0.0 Resetting,
QUIT,