Error Code 32512 during SSH Application Password Check-in

  • 7018022
  • 06-Sep-2016
  • 06-Sep-2016

Environment

NetIQ Privileged Account Manager

Situation

Configured Application SSH Password Checkout feature, fails to check-in password after being checked-out
User selects the Check-In icon and the status shows Failed Check-in
The following error appears in the unifid.log:
Info, SSH User Password Reset - Failed with error code : 32512

Resolution

The following file needs to be made available on the server responsible for SSH Password Check-In:
/opt/netiq/npum/bin/changepasswd

Cause

The required changepasswd binary file is missing from the required bin directory. Error code 32512 is an error from the Perl script reporting the file is unavailable.