iPrint client prompting authentication for non-SSL printers

  • 7017963
  • 19-Aug-2016
  • 26-Aug-2016

Environment

iPrint Appliance 1.1 patch 6
iPrint Appliance 2.0 patch 2
iPrint Appliance 2.1

Situation

When attempting to install an iPrint printer from the /ipp page, the iPrint client prompts the user for credentials, even though the printer is not SSL enabled.

Resolution

Load the /ipp page using the address to which the print manager is bound.  To determine what that address is, you can:
Run the following command within a terminal session:
cat /etc/opt/novell/iprint/conf/ipsmd.conf | grep PSMHostAddress
or
Look at the Network Address field within iManager -> iPrint -> Manage Print Manager -> look at the Network Address field (just below the "Status:"

If the address bound to the print manager is myprintmanageraddress.company.com, then the URL to load would be:

http://myprintmanageraddress.company.com/ipp

Cause

Using an alternative DNS name to load the /ipp page, even though that alternative name resolves to the same IP address as the print manager's address, will result in non-SSL printers prompting for authentication.  This result might be due to the fix for the security vulnerability 85582 (Click jacking).

Additional Information

This situation has been observed when a workstation had an alternative DNS for the iPrint server within its hosts file.  The alternative DNS name resolved to the IP address of the iPrint Appliance, making it valid.  However, this resulted in the symptom listed above.