NetIQ Acceess Manager Gateway version 4.2.1 receives HTTP 400 Bad Request from web application server

  • 7017879
  • 25-Jul-2016
  • 25-Jul-2016

Environment


NetIQ Access Manager 4.2.1

Situation

  • Access Magare has been upgraded from version 4.2.0 to version 4.2.1
  • Proxy Service has been configured to connect to the web application server using SSL
  • Web Server does not listen on HTTPS / SSL stanadard port 443

  • Since upgrading the protected  Web Servers report HTTP 400 Bad Gateway on each request

Resolution

  • As a current workaround configure the problem relarted Proxy Service to connect to HTTPS standard port 443 and use the following iptbaes rule to redirect outgoing traific to the listening port of the Web Server:

    "iptables -t nat -A OUTPUT --dst [Web Server IP Address] -p tcp --dport 443 -j DNAT --to-destination :[Web Server Listening Port]"


  • The issue has been addressed to engineering

Cause

The problem is caused bt the new Apache version shipped with Access Manager 4.2.1: "novell-nacm-apache-2.2.27"