Environment
NetIQ PlateSpin Protect 10.x, 11.x
NetIQ PlateSpin Forge 3.x, 4.x, 11.x
NetIQ PlateSpin Migrate 12.x (Web Console)
NetIQ PlateSpin Forge 3.x, 4.x, 11.x
NetIQ PlateSpin Migrate 12.x (Web Console)
Situation
A workload, for which is replication job is running, can no longer be aborted.
Resolution
1) On the PlateSpin server, run the command:
sqlcmd -E -S .\platespindb -Q “Select ID from protection.dbo.workloads where DiscoverySourceAddress like ‘[IP address of the workload]’”
or if the first command fails try the command below:
sqlcmd -E -S .\platespindb -Q “Select ID from protection.dbo.workloads where DiscoverySourceAddress like ‘[hostname of the workload]’”
The outcome should return the ID of the workload you were trying to add
2) Then run:
sqlcmd -E -S .\platespindb -Q "update protection.dbo.workloads set protectionstate = 18, workflowstep = NULL, lastoperationid = NULL where Id = '[ID found previously]'"
See example below, while adding a workload with IP address 10.46.8.50:


sqlcmd -E -S .\platespindb -Q “Select ID from protection.dbo.workloads where DiscoverySourceAddress like ‘[IP address of the workload]’”
or if the first command fails try the command below:
sqlcmd -E -S .\platespindb -Q “Select ID from protection.dbo.workloads where DiscoverySourceAddress like ‘[hostname of the workload]’”
The outcome should return the ID of the workload you were trying to add
2) Then run:
sqlcmd -E -S .\platespindb -Q "update protection.dbo.workloads set protectionstate = 18, workflowstep = NULL, lastoperationid = NULL where Id = '[ID found previously]'"
See example below, while adding a workload with IP address 10.46.8.50:


Cause
This is a problem with the underlying database not being updated. This can be a sign of database corruption.