Environment
Novell ZENworks Mobile Management 3.1 and prior
Apple Volume Purchase Program Apps
Apple Volume Purchase Program Apps
Situation
Uploading the VPP token into the ZMM
dashboard, the VPP apps never appear in the Managed App list.
The token is successful and pulls the proper expiration date, but
will not see any of the managed apps associated to the token in the
UI.
The following error is present in the iOSMDMSync log on the server:
Log Code: 101Function Name: CRestClientBase::IssueCommand
Description: Exception Caught
Details: Error calling ParseResponse. Error code: 0 Error Message: LargestUInt out of Int range
Resolution
Upgrade ZMM to version 3.2.2 and the VPP apps will properly appear as intended.
Cause
Apple made a change to the length of the string identifying the
apps.
ZMM was not able to handle that change properly in versions 3.2.1 and older.
ZMM was not able to handle that change properly in versions 3.2.1 and older.
Additional Information
Fixed in ZMM 3.2.2 update.