Error "Workload cannot be added. Please ensure the hostname or IP does not match an existing workload or a protection or failback target" when adding a workload

  • 7017585
  • 06-May-2016
  • 28-Jun-2016

Environment

PlateSpin Protect 10.x, 11.x
PlateSpin Forge 4.x, 11.x
PlateSpin Migrate 9.x, 11.x, 12.x

Situation

When adding source workloads, failback targets or discovering a server, you may face the pre-validation error message:
"Workload cannot be added. Please ensure the hostname or IP does not match an existing workload or a protection or failback target".



Note: The error message as it appears can vary from Migrate to Protect / Forge.

Resolution

Recommended: capture snapshot of the PlateSpin server prior to proceeding (to be deleted afterwards).

1) On the PlateSpin server, in the PlateSpin installation folder -> bin, use platespin.browser.exe or ofx.browser.exe to locate the duplicate (either via IP or hostname).
Highlight it, then right click -> view source, copy the machine ID.





2) Then via SQL management Studio (Express), connect to the PlateSpin database.

3) Expand ofx -> Pragrammability -> Stored procedures -> righ click on "dbo.DeleteDevice" -> execute stored procedure.
Enter the machine ID into single quote 'xxxxxxxxxxx', and press OK.









4) Then, re-add the workload / rediscover the source server.

Cause

If the task to remove a source workload, failback target or undiscover a server did not run properly, the workload may be removed from the user interface while some related entries remain in the database.
This would cause a conflict.