Environment
iPrint Appliance 1.1 patch 4 and higher
Situation
When enabling auditing on a printer and printing using the email feature of the appliance, the name registered on the audit file is the email address of the sender and not the CN name of the user
Resolution
1. Verify that imported users have on the source object the email-id configured before getting imported into the appliance. For example:
FQDN:cn=usa,o=novell,dc=net.
UID:usa
Email-ID:usa.novell@domain.com
2. Open "/etc/opt/novell/iprintmobile/conf/iprintmobile.conf" file.
3. Include "audit_common_name=true" at the end.
4. restart mobile server:
rcnovell-iprint-mobile restart
Now when user sends a print job thru email, his email address is matched to his CN and only the CN is sent to the audit service, in this case only "usa" will be sent.
FQDN:cn=usa,o=novell,dc=net.
UID:usa
Email-ID:usa.novell@domain.com
2. Open "/etc/opt/novell/iprintmobile/conf/iprintmobile.conf" file.
3. Include "audit_common_name=true" at the end.
4. restart mobile server:
rcnovell-iprint-mobile restart
Now when user sends a print job thru email, his email address is matched to his CN and only the CN is sent to the audit service, in this case only "usa" will be sent.
Cause
This feature (audit_common_name) is not enable by default. It has to be enabled manually
Additional Information
More information about the parameter will be in "/etc/opt/novell/iprintmobile/conf/iprintmobile.conf.template" file