Unable to execute mountvol : return code : -9 output

  • 7017406
  • 24-Mar-2016
  • 13-Jun-2016

Environment

Novell ZENworks Configuration Management 11.2 Migration

11.2.x 32-bit Primary migrating to 11.2.x 64-bit Primary
(11.2.x Primary servers have same version and subversion)

Situation

ZENworks Migration utility (11.3.0a.iso) wizard used to migrate ZENworks from 32-bit to 64-bit OS.
D:\>  Setup.exe  -R

ZENworks_Server_Migration_<DateTimeStamp>.log.xml displays;
Unable to execute mountvol : return code : -9 output ::
Unable to execute mountvol : return code : -9 output ::


Progressing through wizard it hangs on "Please Wait" screen before "Summary" screen.
"Summary" page never comes up, hence never starting the migration.






Resolution

Redirected IIS using port 80, to 8080 and restarted IIS services.
Reinstalled new 64-bit Primary Server into the zone for migration to the same version/subversion.
Checked server.xml log for accuracy.
Started Migration
Migration wizard "Summary" page took a while to present, but finally allowed for "Install"


Cause

Found that %ZENWORKS_HOME%\share\tomcat\conf\server.xml setting was configured for non-SSL - port 443.

 <!-- Define a non-SSL HTTP/1.1 Connector on port 80 -->
    <Connector port="443" protocol="HTTP/1.1"


This caused ZENworks to be configured with non-SSL port of 443 which is an invalid configuration.

Additional Information

Start the ZENworks migration in Debug mode by holding the control key (CTRL) down while setup.exe is extracting.
Note: This debug window closes when migration is complete or terminated.

Check;
- devices are on same subnet
- 32-bit Primary UserID entered in Migration wizard authentication has local administrator rights on 32-bit Primary
- proper ports are being used in setup - server.xml
- during wizard a drive mapping should appear (on Windows typically Z:)