Sentinel 7.4.1 SDK reports functionality workaround

  • 7017293
  • 24-Feb-2016
  • 03-Mar-2016

Environment

NetIQ Sentinel 7.4.1 SDK Report

Situation

Sentinel 7.4.1 SDK report creation not working.

Resolution

1. Changed Line 430 plugin-sdk/current/sdk/resources/connection.xml as follows:

<property name="jarlist" value="contentinstaller.jar,ccsapp*.jar,ccsbase*.jar,communications*.jar,dataobjects*.jar,
libuuid*.jar,reports*.jar,sentinel-client-base-java*.jar,sentinel-client-base*.jar,sentinel-logging*.jar,
sentinel-crypto*.jar,activemq*.jar,concurrent*.jar,jasperreports*.jar,postgresql*jdbc4.jar,serializer*.jar,xalan*.jar,
sentinel*fonts*.jar,log4j*.jar,geronimo-jms*.jar,geronimo-j2ee-*.jar,hawtbuf*.jar"/>

2. Create a new connection to server.

3. If a connection is existing to the server then edit it and provide the password , it will re-download the jars from the server.

Cause

In 7.4 Service Pack 1, a number of important security updates to Sentinel's third party libraries resulted in the SDK's connection-building routine no longer downloading the correct set of binaries.