Linux agent keeps trying to install novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1

  • 7017175
  • 20-Jan-2016
  • 20-Jan-2016

Environment

Novell ZENworks Configuration Management 11.4.1 Installation - Agent
Novell ZENworks Patch Management 11.4.1

Situation

The ZENworks 11.4.1 agent has been installed on a Linux device.
ZENworks Patch Management is enabled for the device.
The ZENworks agent component manager keeps trying to install novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1 on each general refresh.

The install fails with a message in /var/opt/novell/zenworks/logs/LocalStore/zmd-messages.log which looks similar to:
"...
[TRACE] [01/20/2016 21:15:55.631] [2519] [ZenworksAgent] [184] [] [PackageSourceService] [] [Failed to download install package novell-zenworks-libsolv-helpers-11.4.1_0.6.6-6.1.<x86_64 or i586>.rpm from remote source(s)] [] [] [] [ZENworks Agent]
..."


Resolution

In most cases there is no functional impact. Please read the Additional Information section for more detail.

Cause

The ZENworks agent configuration has been updated to look for a 11.4.1_0.6.6-6.1 version of the novell-zenworks-libsolv-helpers rpm while there has not been included a newer version of this rpm in 11.4.1. The current version is still 11.4.0_0.6.6-6.1.

Status

Reported to Engineering

Additional Information

As long as the 11.4.0_0.6.6-6.1 version of the novell-zenworks-libsolv-helpers rpm is installed, there is no functional impact.

In case the rpm got uninstalled e.g. because the Patch Management ZENworks agent component got temporarily uninstalled or Patch Management gets enabled at a later point of time after the 11.4.1 install or update, a manual install of the rpm might be required.

The install source for the rpm is located at:
- Linux Primary Server: /opt/novell/zenworks/install/downloads/rpm/
- Windows Primary Server: %zenworks_home%\install\download\rpm
Below there is a subfolder named after the general Linux platform like sles-11-i586 (for SLED & SLES 11 x86 devices) or sles-12-x86_64
In the corresponding subfolder you find the required build of the novell-zenwork-libsolv-helpers rpm with version 11.4.0_0.6.6-6.1.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.