The firstboot.xml fails to configure networking

This document (7017136) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)

Situation

When using the default /etc/YaST2/firstboot.xml file, the network never gets configured even though the rest of the installation works fine. The firstboot.xml file contained the following network module:

<module>
  <label>Network</label>
  <name>inst_proposal</name>
  <enabled config:type="boolean">true</enabled>
  <proposal>firstboot_network</proposal>
 </module>

Resolution

Replace any occurrence of this in your firstboot.xml
<module>
  <label>Network</label>
  <name>inst_proposal</name>
  <enabled config:type="boolean">true</enabled>
  <proposal>firstboot_network</proposal>
</module>
With this:
<module>
  <label>Network</label>
  <name>inst_lan</name>
  <enabled config:type="boolean">true</enabled>
</module>

Cause

Invalid network configuration module.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7017136
  • Creation Date: 08-Jan-2016
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center