GroupWise Sync Agent shows a status of Stopped in the GroupWise Mobility Service Web portal

  • 7017112
  • 29-Dec-2015
  • 22-Feb-2016

Environment

Novell GroupWise Mobility Service 2014 R2

Situation

The GroupWise Sync Agent shows a status of Stopped in the GroupWise Mobility Service 2014 R2 Web portal.  The mobility services start fine with "rcgms start" and there is no indication of a problem until you login to the Web portal.  When you attempt to restart the GroupWise Sync agent in this web portal you get the error : "An error has occurred starting the sync agent. "  Show details reveals the error : "Error: Please verify that the connector Manager is running and that the connectors.xml is correctly configured."  The content of this xml file is correct. 

Resolution

It was discovered that there was a minor error in the Config, GroupWise, POA Soap Address port.  The value normally should be ( in GMS 2014 R2 ) <ipAddressOfPOABox>:7191, but the customer had <ipAddressOfPOABox>:7191/soap .
Once we removed /soap and restarted GMS with "rcgms restart" the problem went away.
 
Updated Information: 
Another customer with this same issue did not run the update.sh script (needed when you upgrade from GMS 2.1 to GMS 2014 R2), located in the /opt/novell/datasync/ directory. Once this was done and in the GMS 2014 R2 Web Admin console, Config, GroupWise, the "POA SOAP Address Port" was changed from http://<POAIPAddress>:7191 to just "<POAIPAddress:7191"  (no quotes) , then the problem went away after restarting GMS with rcgms restart.  In this customer case, the log file errors noted in this TID's "Additional Information" was also seen.

Cause

As a result of simplifying some configuration selections in the newer version of GMS 2014 R2 over the previous version of GMS 2.1, it is now not correct to add the /soap to the url of the POA soap url.  The customer mistakenly copied it from an older GMS 2.1 server configuration and transferred it to the new server.

Additional Information

It should be noted that the errors that was generated in the Mobility groupwise-agent.log in the /var/log/datasync/connectors/ directory for this issue was :

  EXCEPTION: Exception: GroupWise SOAP address format has changed.  The correct format is: [DNS:port] 

The other symptom of this problem was that they could not run the mcheck script in the /opt/novell/datasync/tools/mcheck/ directory, the script being called mcheck.pyc.  The solution for this issue was the same as described above in the Resolution section.