Environment
Novell Service Desk 7.0.3 Reports
MySQL Database
MySQL Database
Situation
- Running the report: Service Agreements > All Processes > Requests SLA Times by SLA
- No results are shown
- No headers are shown
ERROR:
(ReportSLA.java:1853) - An unknown error occurred
java.lang.NullPointerException
at com.livetime.reports.utils.ReportSLA.timeBySla(ReportSLA.java:1772)
Resolution
Contact Micro Focus Customer Care for a script to cleanup corrupt
entries in the database.
Cause
There were NULL values in the time_mins column of the sla_contract table in the Service Desk
database.