Cabinet Maker popup during Patch Management remediation

  • 7017038
  • 01-Dec-2015
  • 28-Jul-2016

Environment

Novell ZENworks Configuration Management 11.3
Novell ZENworks Patch Management 11.3

Situation

Cabinet Maker popups during patch remediation.




Resolution

To avoid user interaction during patch remediations see "How to set Patch Remediation bundles to run as System user"  https://support.microfocus.com/kb/doc.php?id=7016883

Cause

ZPM deployment bundles or remedate.exe actions do not call makecab.exe directly.

The makecab.exe popup is a result of CBS log rotation (CBS is Component-Based Servicing), which is a Microsoft process (sfc.exe).  The CBS log is written and updated when components are installed, updated or uninstalled.  The CBS log grows during the ZPM DAU (Discover Applicable Update) process and during the patch deployments.  When the CBS.log reaches about 50 MB in size the log rotates and CBS.log is compressed into a CAB file.  This is done by the Cabinet maker, makecab.exe

During patch vulnerability scan or deployment, the compression by makecab.exe happens under Dynamic Administrator session which will interact with the user desktop.