ZENworks agent will not start

  • 7016992
  • 16-Nov-2015
  • 31-May-2016

Environment

Novell ZENworks Configuration Management 11
Microsoft Windows 7

Situation

The ZENworks agent will not start.

Error as seen in services.msc:

ERROR:
The Novell ZENworks Agent service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

Error when zac commands (zac cc, zac retr, zac reg, zac ref) are in run in command prompt:

ERROR:
Exception: Failed to connect to an IPC Port: The system cannot find the file specified.

Error as shown in Application.evtx:

ERROR:
The ZENworks agent

Service cannot be started. System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
   at ZENWindowsService.Service1.DeviceJustImaged(Boolean debug)
   at ZENWindowsService.Service1.DeviceJustImagedFlag()
   at ZENWindowsService.Service1.WaitforZiswin(Boolean& justImaged, Boolean overrideJustImaged)
   at ZENWindowsService.Service1.OnStart(String[] args)
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

Resolution

1. Open Registry Editor (may require run as "Administrator")
2. Go to HKLM->Software->Microsoft->.NETFramework->Enable64Bit and modify the value to 1
3. A restart of the system may be necessary

Cause

Likely third party software disabled .NET.