ZENworks Server Service fails to start after applying workaround in TID 7015138

  • 7016892
  • 08-Oct-2015
  • 08-Oct-2015

Environment

Novell ZENworks Configuration Management 11.3.1 Diagnostics
Microsoft Windows Server

Situation

  • Applied workaround in TID 7015138
  • ZENworks Server Service fails to start
  • ZENworks Control Center (ZCC) will not load

The following is seen in the Java tab of %ZENWORKS_HOME%\bin\zenserverw.exe:

-Dcom.sun.management.jmxremote=true
-Dcom.sun.management.jmxremote.port=3030
-Djava.rmi.server.hostname=<server ip/hostname>

Resolution

  1. Remove the following from the Java tab of %ZENWORKS_HOME%\bin\zenserverw.exe:
    -Dcom.sun.management.jmxremote=true
    -Dcom.sun.management.jmxremote.port=3030
    -Djava.rmi.server.hostname=<server ip/hostname>
  2. Follow the Resolution steps from TID 7015138 again

Cause

Settings were in place to enable JMX on the Windows server. The steps were found in a TID that is only applicable for ZENworks versions before ZENworks 11.3.