Environment
Acess Manager 3.X
Acess Manager 4.X
Situation
Kerberos won't be able to authenticate against the KDC. One can see the "commit succeed" message on the log but it is followed by a error message: "Could not initialize Kerberos/GSS No valid credentials provided (Mechanism level: Failed to find any Kerberos credentails)"
Resolution
In the Admin Console, edit the IDP cluster configuration. Go to the local tab and click on class. Edit the Kerberos class you created, go to the properties and make sure the realm is in upper case. If it is on lower case, one will have to remove and re-create the class. Just switching the content of the realm field from lower case to upper case won' t suffice.
Cause
Because our IDP uses java and java is case-sensitive, it is necessary that the realm is configured in upper case.