How to resolve renamed server objects

  • 7016792
  • 25-Aug-2015
  • 25-Aug-2015

Environment

NetIQ AppManager Enterprise 8.2
NetIQ AppManager Enterprise 8.0.3
NetIQ AppManager Enterprise 8.0.2
NetIQ AppManager Enterprise 8.0.1

Situation

When renaming an Agent server object, the QDB and NQCCDB retains the old server object's name causing it to now have two different server object names for the same server with the same AuthoritativeID which will cause synchronization issues.

Resolution

On the renamed machine.

1. Stop Agent services (mc & ccm)

2. Remove the 3 db files located at C:\Program Files (x86)\netiq\Common
   a. Version.db
   b. Appdetection.db
   c. Si.db

3. Delete AuthoriativeID from the renamed Agent located in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NetIQ\AppManager

4. In OC, get objid from old server name object by highlighting server object and pressing ALT+F8.

5. Make note of the ObjID value for that server

6. Delete old server name object from CC or OC and add new Agent.
 
7. Coldstart agent services with –oa

8. Remove old object name from the objects table by running the query below against the QDB
  
             Update object set status = 134217728 where objid = <objid>

   Please be sure to replace <objid> in the above query, with the actual ObjID value from Step 5.
 
9. Run NetIQ daily QDB

Cause

Renaming a server object.