Environment
Novell Client 2 SP4 for Windows
Microsoft Windows 7
Situation
After entering the user's credentials in the Novell Client Credential Provider, the login script(s) does not execute, and the user is left at a blank screen. It is possible to launch Task Manager and manually run EXPLORER.EXE in order to access the desktop, then login again from the "Red N" in order to execute the login script(s).
Resolution
Apply the Microsoft hotfix from Microsoft KB Article 2719306.
Cause
The problem is caused by a deadlock within the Windows 7
process heap management between "real memory management
calls" being made on one thread, and "Heap32Next diagnostic calls" being made on
another thread.
Additional Information
An alternative to applying the Microsoft hotfix can be
to use clear-text rather than TLS/SSL connections for the LDAP servers in LDAP
Contextless Login (assuming LDAP contextless login is enabled/being used). This is set in: Red N > Novell Client Properties > LDAP Contextless Login tab > Server IP address > Properties > "Unencrypted Data".