Remote Diagnostic fails with error: "The connection has been closed by the managed device"

  • 7016535
  • 22-May-2015
  • 26-May-2015

Environment

Novell ZENworks Configuration Management 11.3 Remote Management
Microsoft Windows 8.1
ESET NOD32 Antivirus

Situation

  • HIPS (Host-based Intrusion Prevention System) enabled in ESET NOD32 Antivirus
  • Disabling ESET NOD32 Antivirus does not prevent the error
  • Running ZENworks Remote Diagnostic to diagnose a problem

The following could be seen in ZCC (ZENworks Control Center):

ERROR:
The connection has been closed by the managed device

The following could be seen in the zmd-messages.log:

ERROR:
[nzrInjector] [3232] [] [Remote Management] [] [Failed to allocate memory.]
[nzrInjector] [3232] [] [Remote Management] [] [Failed to inject dll.]

Resolution

Add an exclusion for nzrInjector.exe to the HIPS policy in ESET NOD32 Antivirus.
Please contact ESET for specific direction on how to do that.

Cause

The underlying error is:
Error 5: Access Denied

Additional Information

nzrInjector.exe can be found in %ZENWORKS_HOME%\bin\ .