Environment
Novell Client 2 SP3 for Windows
Situation
Suddenly, one user can no longer login. Any attempt to login using either the Tree or Server's name or the Tree or Server's IP address, results in an immediate "Tree or server not found" type error.
Resolution
Disable or remove the firewall blocking port 524 access.
Cause
Observing the running applications in Task Manger revealed that the user had installed the AVG firewall. This was in addition to the Windows firewall, which was also installed and properly configured.
Additional Information
The user was able to TELNET to the NCP port 524 (from an elevated command prompt, type "telnet <ip address> 524"; if telnet is not on the system, install using the command line "pkgmgr/iu:"TelnetClient""), so a problem with a firewall was initially ruled out. This is evidence that TELNET, as a user-mode program running on the desktop (via Winsock) may be able to successfully TELNET over port 524, while the firewall is simultaneously disallowing kernel-mode connections from drivers.