Environment
Novell GroupWise Mobility Service
Situation
After rebooting the mobility server after installing a new GMS install has been completed, the webadmin shows "AttributeError - Could not connect to the ConfigEngine"
When trying to restart GMS the following error is seen: WARNING: Some datasync service(s) had a problem shutting down. Please see the README for details
Resolution
To fix the server without rebooting, follow the steps below:
- Check for the python process by launching a terminal session
- At the terminal prompt, type ps -aux | grep python
- If python process are returned, type killall -9 python
- Start GMS by typing rcgms start
- If all comes up properly, verify that everything is now working
If the steps above correct the issues, proceed with the following instructions
- Type chkconfig gms off
- Type chkconfig | grep datasync to verify results containing datasync say on
- Reboot the server and services should come up properly
Cause
duplicate processes try to start up on the server with a new install of 2.1