Environment
Novell iPrint Appliance
Situation
Attempting to rename a printer within the iPrint Appliance Management Console results in the following error:
An error has occurred. See the server logs for more information.Note: The steps to rename a printer are:
iPrint Appliance Management Console (https://<IP or DNS>:9443) -> iPrint Appliance Configuration -> Printers -> Highlight the Printer -> Configure -> Rename Printer
Resolution
Resolution 1: Change the admin password using the recommended method
- Change the admin password back to the original password.
- iManager -> Directory Administration -> Modify Object -> browse to the admin.iPrintAppliance user -> Restrictions -> Set Password -> change the password to the original.
- If you need the password changed, change it using the recommended method:
- Access the iPrint Appliance from a terminal session
- Log in as root
- Type the following command:
- /opt/novell/bin/iprint_edir_change_passwd.sh
- Enter edir password : <type the current password here and hit ENTER>
- Enter new edir password : <type the new desired password here and hit ENTER>
- ReEnter new edir password : <again, type the new desired password here and hit ENTER>
Resolution 2: Update the iPrintman.keystore to the 1.1 server.
- Shutdown the current Appliance
- Start the previous 1.0.1 iPrint Appliance
- Copy the /var/lib/wwwrun/iPrintman.keystore file to a location other than the server.
- Shutdown the 1.0.1 iPrint Appliance
- Start the 1.1 iPrint Appliance
- Copy the iPrintman.keystore file from the 1.0.1 server to /var/lib/wwwrun/ on the 1.1 iPrint Appliance
- Set the proper ownership on the file
- chown wwwrun.www /var/lib/wwwrun/iPrintman.keystore
- Log out of the iPrint Appliance Management Console
- Log in and rename the printer
Workaround:
Use iPrintman to rename the printer. Within a terminal session, type the following:
Syntax:
iprintman printer <existing_printer_name> -n <new printer name>
Example:
iprintman printer HPLJ4020-2ndFLR -n HPLJ4020-3rdFLR
Cause
Cause 1: Admin password changed using iManager
Changing the admin password within iManager is not recommended and will result in the error listed above.
Cause 2: 1.0.1 Appliance upgraded to 1.1 doesn't doesn't update the iPrintman.keystore file
When upgrading from the Appliance 1.0.1 to version 1.1, the /var/lib/wwwrun/iPrintman.keystore should be copied from the older server to the new server. However, it is not. Failing to update this file results in the error listed above.
Changing the admin password within iManager is not recommended and will result in the error listed above.
Cause 2: 1.0.1 Appliance upgraded to 1.1 doesn't doesn't update the iPrintman.keystore file
When upgrading from the Appliance 1.0.1 to version 1.1, the /var/lib/wwwrun/iPrintman.keystore should be copied from the older server to the new server. However, it is not. Failing to update this file results in the error listed above.