Cannot install SMT client on Access Gateway following the documentation

  • 7016284
  • 10-Mar-2015
  • 12-Mar-2015

Environment

NetIQ Access Manager 3.2
NetIQ Access Manager 4.0

Situation

Admin tried to install and enable the SMT client following the documentation at https://www.netiq.com/documentation/netiqaccessmanager4/target_mig_upgrade/data/bpxes3m.html. When installing the smt client, the admin gets the following error message:

error: Failed dependencies: perl-IO-Socket-SSL is needed by smt-client-0.0.16-0.5.1.x86_64

Without the smt-client installed, you cannot check the status of the updates on the client from the SMT management console. See https://www.suse.com/documentation/smt11/book_yep/data/smt_yast_staging_client.html - until smt-client is installed, the status will be "unknown" instead of "up-to-date" or "updates-pending"
  

Resolution

Fixed in NAM 4.1.

Cause

NAM 4.0/3.2 is missing some dependencies to get the client working. These have been included in 4.1 where we include the following rpms in both MAG & NAM appliances by default.

perl-IO-Socket-SSL-1.38-5.2.2
perl-Net-SSLeay-1.35-2.14
smt-client-0.0.18-0.5.1

Feedback service temporarily unavailable. For content questions or problems, please contact Support.