unable to login to SCM

  • 7016232
  • 25-Feb-2015
  • 26-Feb-2015

Environment

NetIQ Secure Configuration Manager 6.0

Situation

Unable to login to SCM.  After entering login credentials you get an error that says it cannot connect to core services.

Error in the core log:

ERROR [main] [PoolManager] Failed to get database connection!
java.sql.SQLException: Network error IOException: Connection refused: connect


Resolution

Stop the NetIQ Core Services service, then stop the SQL Server service.  Start the SQL Server service, then start the NetIQ Core Services service.  Login to SCM.

Cause

This usually happens when the core services machine gets disconnected from the database.  This can happen if the SQL Server is down for maintenance or database backup or if either machine has had Microsoft Updates applied and has been rebooted.  This can happen if the machine that core services is installed on was rebooted before the SQL Server was rebooted.