Environment
Novell Open Enterprise Server 2 (OES 2) Linux
Situation
When checking trustees of a given directory with /opt/novell/nss/sbin/rights, the there appear to be no trustees assigned. Checking the trustees of the same directory with iManager, shows the proper trustees assigned.
Verifying the trustees on the volume with "ncpcon nss verify=volName" yields an error on the directory similar to:
[Trustee difference] path="/PRV/NTS/USER1" fdn=".user1.OU1.OU.novell" ncprights="RWCEMF" nssrights=""
Verifying the trustees on the volume with "ncpcon nss verify=volName" yields an error on the directory similar to:
[Trustee difference] path="/PRV/NTS/USER1" fdn=".user1.OU1.OU.novell" ncprights="RWCEMF" nssrights=""
Resolution
At the time of this writing, OES 2 is out of development support. The best way to resync the trustees is to:
- Log into Novell Remote Manager (NRM) (https://dns_or_ip:8009)
- Navigate to "Manage NCP Services"->"Manage Server"
- In the right pane, find "SYNC_TRUSTEES_TO_NSS_AT_VOLUME_MOUNT" and change the value to "1".
- Dismount the volume in question (offline if it's a clustered volume).
- Mount the volume in question (online if it's a clustered volume).
This will sync the trustees. - Repeat steps 4-5 for any other effected volumes.
- When all volumes are remedied, change the value of "SYNC_TRUSTEES_TO_NSS_AT_VOLUME_MOUNT" (#3 above) back to "0".
- Log out from NRM.
Cause
The NCP and NSS list of trustees are out of sync.