Missing domain .dc files causes administrative updates to not get written to the secondary domain

  • 7016132
  • 02-Feb-2015
  • 02-Feb-2015

Environment

Novell GroupWise 2014

Situation

Problem:
Newly created GroupWise users under a primary domain post office do not get synchronized to a secondary domain that owns the GWIA.  As a result these same GroupWise users are not able to receive internet mail.  Sender gets undeliverable message.




Resolution

Copy the *.dc files from the primary domain directory to the GroupWise secondary domain directory that is missing the .dc files and restart the MTA.

Cause

It was discovered that the secondary domain that owns the gwia did not have any .DC files in the domain directory, once they were copied in from
the primary domain directory and the secondary domain MTA restarted, then both the user sync and undeliverable problems went way.

Additional Information

With no .DC files in the GroupWise domain directory, the GWMTA agent still loads fine and routes existing user internet e-mail fine, but will not
process administrative messages.  The admin messages that failed to process during this issue never pile up in the /SecondaryDomain/../2 queue.
NOTE: Another side issue as the result of not having .DC files in the domain directory, is that when you go to http://<GWSecDomIPAddress>:7180, when you go to Configuration, Admin Task Processing, the result is that the screen will then show a blank white screen with no information about the administrative task.
The admin update seems to process and get deleted as the result of normal processing , but the administrative changes (new gw user) never gets written
to the secondary domain (with no .dc files) database.