New Events are not being received and/or MS Actions stop occurring

  • 7016048
  • 09-Jan-2015
  • 21-Jan-2015

Environment

NetIQ AppManager 8.2
NetIQ AppManager 8.0.x

Situation

New Events stop appearing in Control Center/Operator Console and MS Actions stop occurring

Resolution

If you do not see similar entries in your MS log as those listed in the Cause section, then do the following:

1- Stop all the NetIQ services on the Management Server that exist (NetIQ AppManager Client Resource Monitor, NetIQ AppManager Client Communication Manager, NetIQ AppManager Management Service)

2- Rename the PIOCEVENT file to PIOCEVENT.old,

The PIOCEvent file by default is located here:

<install directory>\NetIQ\AppManager\dat\pioc

3- Cold start the NetIQ AppManager services that were stopped on step 1 above (-oa start parameter for NetIQ AppManager Client Resource Monitor and NetIQ AppManager Client Communication Manager and -o start parameter for the NetIQ AppManager Management Service)

4- Restart the SQL Server and SQL Server Agent Services on the Microsoft SQL Server hosting the Repository/QDB.

5- Monitor Management Server and see if Events and Actions are processed properly now.

If you see similar entries in your MS.log as listed in the Cause section do the following:

1- Stop all the NetIQ services on the Management Server that exist (NetIQ AppManager Client Resource Monitor, NetIQ AppManager Client Communication Manager, NetIQ AppManager Management Service)

2- Open Registry and navigate to HKEY_LOCAL_MACHINE\Software\NetIQ\AppManager\4.0\NetIQMS\Config\Event Thread

3- Modify the value of the above key from decimal value of 1 to 3

4- Start all the NetIQ services on the Management Server 

5- Monitor Management Server and see if Events and Actions are processed properly now.

Cause

This can be caused by either a corrupt PIOCEvent file or the Event thread getting stuck while sending FullEvent uncollapse requests to the agent machine through RPC interface between the Management Server and the Agent and not timing out.

You may see statements like the following in the MS.log file (by default this log would be located in the <install directory>\NetIQ\Temp\NetIQ_Debug\<servername>\ directory):

MSUncollapseEvent_V40: sending job status request to machine XXX.XXX.XXX.XXX
where XXX represent the IP address of an agent