Secure Workstation Service does not have an active policy

  • 7015991
  • 12-Dec-2014
  • 12-Dec-2014

Environment

NetIQ SecureLogin
NSL8.0.1
SecureWorkstation Local policy configured
No NMAS policy configured for Secure Workstation


Situation

Error returned stating that Secure Workstation does not have an active policy.

Error occurs when clicking "View Effective Policy" in the Secure Workstation’s main dialog after logging in to eDirectory and the workstation.

Resolution

Fix the path to the SecureWorkstation service wsaccsmp.exe in the registry.  Perform the following steps:

1. Set [HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NMAS\MethodData\Secure Workstation\Allowed Processes]
"1"= "C:\Program Files\NetIQ\SecureLogin\wsaccsmp.exe"

2. Under [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
set the path for SecureWorkstation to "C:\Program Files\NetIQ\SecureLogin\wsaccsmp.exe"

3. Finally, to make wsaccsmp to start automatically after editing the policy and restarting:
Go to Run-> msconfig -> startup tab -> check the checkbox for SecureWorkstation. Make sure the path showing the registry setting is stated correctly.

Cause

Path to the SecureWorkstation service launcher (wsaccsmp.exe) is entered incorrectly by the installer.

Status

Reported to Engineering