Environment
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 1
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 2
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 2
Situation
During the automatic common proxy user password change (every 30 days), the following was observed in
/var/log/messages:
change_proxy_pwd.sh[19311]: ERROR: Retrieving the LUM proxy username from CASA failed
In checking the /var/opt/novell/log/proxymgmt/pxymgmt.log, the following is observed:
Retrieving LUM proxy username from CASA
Executing command: /usr/bin/lum_retrieve_proxy_cred username /etc/opt/novell/proxymgmt/proxyuser.txt
Retry attempt 2
Retry attempt 3
Retrieving the LUM proxy username from CASA returned: 255
ERROR: Retrieving the LUM proxy username from CASA failed.
/var/log/messages:
change_proxy_pwd.sh[19311]: ERROR: Retrieving the LUM proxy username from CASA failed
In checking the /var/opt/novell/log/proxymgmt/pxymgmt.log, the following is observed:
Retrieving LUM proxy username from CASA
Executing command: /usr/bin/lum_retrieve_proxy_cred username /etc/opt/novell/proxymgmt/proxyuser.txt
Retry attempt 2
Retry attempt 3
Retrieving the LUM proxy username from CASA returned: 255
ERROR: Retrieving the LUM proxy username from CASA failed.
Resolution
This has been fixed with January 2015 maintenance (and later). Therefore, you will want to apply current maintenance to your server.
Cause
LUM was not configured with a proxy. So when the change
password script goes to verify LUM's proxy, it encounters an error (as
it doesn't exist).
Additional Information
A workaround, until you can apply maintenance is to ensure LUM is configured with a proxy (preferably the OEScommonproxy). This can be accomplished via YaST->Open Enterprise Server->...->modify the configuration of LUM to use a proxy. (See Linux User Management for further information.)