Environment
Novell ZENworks Configuration Management 11.3 Deployment
Situation
- ZENworks Adaptive Agent was installed by a Deployment task
- Some deployed devices show up with errors even though they show up as registered under ZCC (ZENworks Control Center) > Devices > Managed
ERROR:
Timeout waiting for device. Check the Application Event Log (Windows) or /opt/novell/zenworks/stage/ZENPreAgent.log (Linux) on the target device
Resolution
To verify which devices still need the ZENworks Adaptive Agent, do
the following:
NOTE: For this to work, the devices will need to be powered on.
- Copy a list of the IP addresses that have an error from ZCC > Deployment > [deployment task] > Results
- Paste these IP addresses into a spreadsheet program such as Microsoft Excel or LibreOffice Calc
- Remove all columns except the plain IP address
- Save the document in the .csv format
- Create a new Discovery task in ZCC > Deployment
- Click Import to import the .csv file from above
- Run the discovery task
NOTE: For this to work, the devices will need to be powered on.
Cause
This error can occur when the device takes too long to respond
during the deployment. This can happen even if the ZENworks
Adaptive Agent is already installed on the device.