Error on Patch Deployment bundles running at older version than primary

  • 7015530
  • 13-Aug-2014
  • 13-Aug-2014

Environment

Novell ZENworks Patch Management 11.3
Novell ZENworks Configuration Management 11.3

Situation

Error on deployment bundles when Patch Primary is updated to 11.3.x but agents are still at 11.2.x.

ERROR (from zcc) 

ActionMan.ExeHandlerNotFound

ERROR (from zmd-messages.log):

[Could not find a Handler associated with the following type: patchReportDeploymentResult.] 

Resolution

The error does not prevent the patch from deploying.  But until all agents are updated the following can be done:

Workaround:

On the patch deployment bundle, go to Actions / Install.  Disable this action "Log patch deployment results".

Feedback service temporarily unavailable. For content questions or problems, please contact Support.